Bench issue (bench: command not found)

When i try to execute bench command, it is giving me following error:

[root@ip-118-139-178-144 ~]# bench init frappe-bench
-bash: bench: command not found

Have you used the easy install script here, https://github.com/frappe/bench#easy-way ?

(no bench command is required to get erpnext running if you use this script)/

Dear i am trying to install because if i i install in easy way, i am facing lot of issues.

Please see the trace given below:

[root@ip-118-139-178-144 ~]# bash setup_frappe.sh --setup-production
Installing for centos 6 amd64
In case you encounter an error, you can post on https://discuss.frappe.io

Adding centos mariadb repo
Installing packages for centos. This might take time…
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: sg2plmirror02.shr.prod.sin2.secureserver.net
  • epel: mirror.smartmedia.net.id
  • extras: sg2plmirror02.shr.prod.sin2.secureserver.net
  • ius: mirror.symnds.com
  • updates: sg2plmirror02.shr.prod.sin2.secureserver.net
    Setting up Install Process
    Package git-1.7.1-3.el6_4.1.x86_64 already installed and latest version
    Package matching libxml2-2.7.6-12.el6_4.1.x86_64 already installed. Checking for update.
    Package libxslt-1.1.26-2.el6_3.1.x86_64 already installed and latest version
    Package libXrender-0.9.7-2.el6.x86_64 already installed and latest version
    Package libXext-1.3.1-2.el6.x86_64 already installed and latest version
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    The program yum-complete-transaction is found in the yum-utils package.
    –> Running transaction check
    —> Package MariaDB-client.x86_64 0:5.5.41-1.el6 will be obsoleting
    –> Processing Dependency: MariaDB-common for package: MariaDB-client-5.5.41-1.el6.x86_64
    —> Package MariaDB-compat.x86_64 0:5.5.41-1.el6 will be obsoleting
    —> Package MariaDB-devel.x86_64 0:5.5.41-1.el6 will be installed
    —> Package MariaDB-server.x86_64 0:5.5.41-1.el6 will be obsoleting
    –> Processing Dependency: libaio.so.1(LIBAIO_0.4)(64bit) for package: MariaDB-server-5.5.41-1.el6.x86_64
    –> Processing Dependency: libaio.so.1(LIBAIO_0.1)(64bit) for package: MariaDB-server-5.5.41-1.el6.x86_64
    –> Processing Dependency: libaio.so.1()(64bit) for package: MariaDB-server-5.5.41-1.el6.x86_64
    —> Package bzip2-devel.x86_64 0:1.0.5-7.el6_0 will be installed
    —> Package libxml2-devel.x86_64 0:2.7.6-12.el6_4.1 will be installed
    –> Processing Dependency: libxml2 = 2.7.6-12.el6_4.1 for package: libxml2-devel-2.7.6-12.el6_4.1.x86_64
    —> Package libxslt-devel.x86_64 0:1.1.26-2.el6_3.1 will be installed
    –> Processing Dependency: libgcrypt-devel for package: libxslt-devel-1.1.26-2.el6_3.1.x86_64
    —> Package memcached.x86_64 0:1.4.4-3.el6 will be installed
    –> Processing Dependency: libevent-1.4.so.2()(64bit) for package: memcached-1.4.4-3.el6.x86_64
    —> Package mysql.x86_64 0:5.1.73-3.el6_5 will be obsoleted
    —> Package mysql-libs.x86_64 0:5.1.73-3.el6_5 will be obsoleted
    —> Package mysql-server.x86_64 0:5.1.73-3.el6_5 will be obsoleted
    —> Package nginx.x86_64 0:1.0.15-11.el6 will be installed
    –> Processing Dependency: nginx-filesystem = 1.0.15-11.el6 for package: nginx-1.0.15-11.el6.x86_64
    –> Processing Dependency: nginx-filesystem for package: nginx-1.0.15-11.el6.x86_64
    –> Processing Dependency: GeoIP for package: nginx-1.0.15-11.el6.x86_64
    –> Processing Dependency: libGeoIP.so.1()(64bit) for package: nginx-1.0.15-11.el6.x86_64
    —> Package openssl-devel.x86_64 0:1.0.0-27.el6_4.2 will be installed
    –> Processing Dependency: openssl = 1.0.0-27.el6_4.2 for package: openssl-devel-1.0.0-27.el6_4.2.x86_64
    –> Processing Dependency: krb5-devel for package: openssl-devel-1.0.0-27.el6_4.2.x86_64
    —> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be installed
    —> Package python-setuptools.noarch 0:0.6.10-3.el6 will be installed
    —> Package python27.x86_64 0:2.7.8-1.ius.centos6 will be installed
    –> Processing Dependency: python27-libs(x86-64) = 2.7.8-1.ius.centos6 for package: python27-2.7.8-1.ius.centos6.x86_64
    –> Processing Dependency: libpython2.7.so.1.0()(64bit) for package: python27-2.7.8-1.ius.centos6.x86_64
    —> Package python27-devel.x86_64 0:2.7.8-1.ius.centos6 will be installed
    —> Package python27-setuptools.noarch 0:7.0-1.ius.centos6 will be installed
    –> Processing Dependency: python27-backports-ssl_match_hostname for package: python27-setuptools-7.0-1.ius.centos6.noarch
    —> Package redis.x86_64 0:2.4.10-1.el6 will be installed
    —> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed
    –> Running transaction check
    —> Package GeoIP.x86_64 0:1.5.1-5.el6 will be installed
    —> Package MariaDB-common.x86_64 0:5.5.41-1.el6 will be installed
    —> Package krb5-devel.x86_64 0:1.10.3-10.el6_4.6 will be installed
    –> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
    –> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
    –> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
    —> Package libaio.x86_64 0:0.3.107-10.el6 will be installed
    —> Package libevent.x86_64 0:1.4.13-4.el6 will be installed
    —> Package libgcrypt-devel.x86_64 0:1.4.5-9.el6_2.2 will be installed
    –> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel-1.4.5-9.el6_2.2.x86_64
    —> Package libxml2-devel.x86_64 0:2.7.6-12.el6_4.1 will be installed
    –> Processing Dependency: libxml2 = 2.7.6-12.el6_4.1 for package: libxml2-devel-2.7.6-12.el6_4.1.x86_64
    —> Package nginx-filesystem.noarch 0:1.0.15-11.el6 will be installed
    —> Package openssl.i686 0:1.0.0-27.el6_4.2 will be installed
    –> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.0-27.el6_4.2.i686
    –> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.0-27.el6_4.2.i686
    –> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.0-27.el6_4.2.i686
    –> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.0-27.el6_4.2.i686
    –> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.0-27.el6_4.2.i686
    —> Package python27-backports-ssl_match_hostname.noarch 0:3.4.0.2-2.ius.centos6 will be installed
    –> Processing Dependency: python27-backports for package: python27-backports-ssl_match_hostname-3.4.0.2-2.ius.centos6.noarch
    —> Package python27-libs.x86_64 0:2.7.8-1.ius.centos6 will be installed
    –> Running transaction check
    —> Package keyutils-libs-devel.x86_64 0:1.4-4.el6 will be installed
    —> Package krb5-libs.i686 0:1.10.3-10.el6_4.6 will be installed
    –> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6_4.6.i686
    –> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6_4.6.i686
    —> Package libcom_err-devel.x86_64 0:1.41.12-14.el6_4.2 will be installed
    —> Package libgpg-error-devel.x86_64 0:1.7-4.el6 will be installed
    —> Package libselinux-devel.x86_64 0:2.0.94-5.3.el6_4.1 will be installed
    –> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.3.el6_4.1.x86_64
    –> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.3.el6_4.1.x86_64
    —> Package libxml2-devel.x86_64 0:2.7.6-12.el6_4.1 will be installed
    –> Processing Dependency: libxml2 = 2.7.6-12.el6_4.1 for package: libxml2-devel-2.7.6-12.el6_4.1.x86_64
    —> Package python27-backports.x86_64 0:1.0-2.ius.centos6 will be installed
    –> Running transaction check
    —> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
    —> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed
    —> Package libxml2-devel.x86_64 0:2.7.6-12.el6_4.1 will be installed
    –> Processing Dependency: libxml2 = 2.7.6-12.el6_4.1 for package: libxml2-devel-2.7.6-12.el6_4.1.x86_64
    –> Finished Dependency Resolution
    Error: Package: libxml2-devel-2.7.6-12.el6_4.1.x86_64 (updates)
    Requires: libxml2 = 2.7.6-12.el6_4.1
    Installed: libxml2-2.7.6-17.el6_6.1.i686 (@updates)
    libxml2 = 2.7.6-17.el6_6.1
    Available: libxml2-2.7.6-8.el6_3.4.i686 (base)
    libxml2 = 2.7.6-8.el6_3.4
    Available: libxml2-2.7.6-12.el6_4.1.i686 (updates)
    libxml2 = 2.7.6-12.el6_4.1
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Okay, the conflict seems strange. You can remove libxml2 from the yum install line in the install script and try again. (try installing on a bare minimal centos install)