Try ERPNext Buy Support Partners Foundation

Bench init erpnext error on CentOS 7

Hello, help pls… I am having an issue initializing bench from my CentOS 7 virtualbox machine. Please see image below for more info.

Hi welcome to ERPNext,

Your install failed since ERPNext now requires python3 to run, while you CentoOS environment has say python2.7.

So try either of these yum install python3 or dnf install python3

[clarkej@tango tmp]$ python -V
Python 2.7.5
[clarkej@tango tmp]$ uname -a
Linux tango 3.10.0-1062.12.1.el7.x86_64 #1 SMP Tue Feb 4 23:02:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

[clarkej@tango tmp]$ python3 -V
Python 3.6.8
[clarkej@tango tmp]$ dnf install python3
Error: This command has to be run under the root user.
[clarkej@tango tmp]$ sudo dnf install python3
[sudo] password for clarkej: 
MongoDB Repository                                                                                                            0.0  B/s |   0  B     00:00    
Failed to synchronize cache for repo 'mongodb', ignoring this repo.
Last metadata expiration check: 0:23:03 ago on Sat 23 May 2020 11:25:38 AM MDT.
Package python3-3.6.8-10.el7.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

thanks! that resolved my first issue on python version, however, bench is still unable to install successfully.

Installing frappe
$ erpnext/env/bin/pip install -q -U -e erpnext/apps/frappe
$ yarn install
[Errno 2] No such file or directory
ERROR: There was a problem while creating erpnext
Do you want to rollback these changes? [Y/n] y
Rolling back Bench “erpnext”
[bench@localhost ~]$

Ok seems yarn was not installed on my CentOS machine. Got everything in place and now Im stuck in creating site having the same issue mentioned at: While creating new-site (MySQL username too long error has occured).