Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

bench.app.InvalidBranchException: Specified branch of app woocommerceconnector is not in upstream

root@app2:/home/frappe/frappe-bench# bench switch-to-branch version-11
LOG: Fetching upstream unshallow for woocommerceconnector
$ git remote set-branches upstream ‘*’
$ git fetch --all --unshallow
Fetching upstream
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/cli.py”, line 41, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/update.py”, line 43, in switch_to_branch
switch_to_branch(branch=branch, apps=list(apps), upgrade=upgrade)
File “/home/frappe/.bench/bench/app.py”, line 417, in switch_to_branch
switch_branch(branch, apps=apps, bench_path=bench_path, upgrade=upgrade)
File “/home/frappe/.bench/bench/app.py”, line 389, in switch_branch
version_upgrade = is_version_upgrade(app=app, bench_path=bench_path, branch=branch)
File “/home/frappe/.bench/bench/app.py”, line 283, in is_version_upgrade
raise InvalidBranchException(“Specified branch of app {0} is not in upstream”.format(app))
bench.app.InvalidBranchException: Specified branch of app woocommerceconnector is not in upstream

The switch-to-branch command will try the action on every app’s branch. In your case, it’s also doing it for the woocommerce app, which doesn’t have the version-11 branch.

You would probably want to specify the apps for which you want to switch the branches.

I think the command to move branches for just frappe and erpnext would be:

bench switch-to-branch version-11 frappe erpnext

Hope that helps!

Thank you now am getting this error message
ERROR: Switching to version-11 will cause upgrade from 10 to 11. Pass --upgrade to confirm
Where do i put the --upgrade flag?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.