Balance report error

Hi everyone,
ERPNext: v6.27.6 - Frappe Framework: v6.27.7
I have this error when i run balance report. I have just create some journal entry for opening balance before. Please help me to solve this issue. Many thanks

Traceback (innermost last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 57, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 19, in handle
execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 36, in execute_cmd
ret = frappe.call(method, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 805, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/desk/query_report.py”, line 88, in run
columns, result = frappe.get_attr(method_name)(frappe._dict(filters))
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/accounts/report/balance_sheet/balance_sheet.py”, line 13, in execute
asset = get_data(filters.company, “Asset”, “Debit”, period_list, only_current_fiscal_year=False)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/accounts/report/financial_statements.py”, line 109, in get_data
calculate_values(accounts_by_name, gl_entries_by_account, period_list, accumulated_values)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/accounts/report/financial_statements.py”, line 127, in calculate_values
d[period.key] = d.get(period.key, 0.0) + flt(entry.debit) - flt(entry.credit)
AttributeError: ‘NoneType’ object has no attribute ‘get’

@toankhanh

Can you provide your chart of accounts

Thanks, Rohit

Hi @rohit_w, i am trying to upload csv file but it does not allowed file type in this forum
How can i upload it.
Thanks

Hi @toankhanh,

Instead of CSV, can you provide screenshots(Not all but one level of asset, liabilities, income, expense) of chart of accounts.

Thanks, Rohit

@rohit_w,
cause of my account list in native language so it could not be help.
may i have any email so that i can send you full of chart of account if you don’t mind,I tested and found that if i creat more than 5 liabilities account for example if i creat sixth account in group of liabilities account and have any entry in this account -> that will make error at balance report. it must be some thing wrong with my abilities account.
Thank you,

Hi @toankhanh,

It seems that there is some problem in asset account not liabilities. Error is coming when system trying to retrieve ledger whose root type is “Asset” from database and their is no value in database. Have you delete asset ledgers?

Thanks

HI @rohit_w,
I found a asset acc. that not apprear in balance sheet, it may be the reason for that
Thanks

Hi @toankhanh I also experience the same problem, could you help me? how to trace the error?

Thanks,