ERPNext Conference 2019* ERPNext.com Blog

Awesome Bar BUG in v10.1.18 - I give up. Let it stay broken


#6

.
.
OK. I have now gone outside of my Google Cloud account and installed the same version on one of my dormant paid servers at InterServer. This is a VPS server with 6gb of memory and plenty of disk space. It is configured with the latest Ubuntu 16.04

This now confirms the error also appeared on this new server. I just went through the production setup again using the following command:

sudo python install.py --production --user bkm

Once installed, I logged in as administrator and went through the initial configuration. I immediately went to the Awesome Bar, type in the word setup, and pressed the Enter key.

I got the same error as I reported at the top of this post. That is a CONFIRMED bug that happens with any new production installs. It doen’t matter what you type into the Awesome Bar, as long as you press the Enter key to start the search it breaks.

Please, someone on the developer side, take a look at this. We cannot afford to have the most valuable tool in the system be broken!

BKM


#7

To Sync help with database instance, you need to execute the bench migrate command.

Thanks
Navdeep


#8

Thanks for the extra input. Mine worked without having to do the bench migrate.

My point for this original post was to get the comunity developers to fix the problem at the install.py script level. Either the install script or one of the functions it calls is broken. The help database is evidently never created (or created and never added) during the install process. It doesn’t matter what you type into the awesome bar, it fails when you press enter key to search.

I just just don’t like leaving known broken issues on the table for the brand new users to stumble over and become afraid of an otherwise great program. The is even more true for a version that is about to be retired (v10) and replaced with the next new set of technologies (v11). We would hope the current version is mature enough to not have such silly issues.

BKM


#9

I can confirm to have the same issue (search something in awesome bar after clean install results in ProgrammingError: (1146, u"Table '1bd3e0294da19198.help' doesn't exist") using a vanilla Debian 8.7 amd64 on the easy install production version with ERPNext: v10.1.18 (master), Frappe Framework: v10.1.16 (master). There were no errors during the setup script. And while this can be easily recovered using

$ bench setup-help

I fully agree with @bkm that this leaves a bad impression with new people trying the system and should be addressed quickly.


#10

Ok, now I am really stuck.

I created a DNS Multitenant server and I get the same error now of all the tenants sites and the fix by @lasalesi doesn’t seem to work for those sites. So I have no way of getting the help database back for the tenant sites at this point.

We need attention to this issue still. :confounded:

BKM


#11

Hi @bkm,

this is strange. When does the error exactly occur? After creating the new site (and affects all others)?

Have you tried

$ bench --site (new-site) setup-help

#12

Yes. That is why I commented that your 2 command fix doesn’t work for the new tenants of a multitenant site.

I am currently rebuilding the server again from the OS all the way up again. It should be ready in about 45 min. I will document the steps from install.py to error with tenants.

BKM


#13

Okay, I must have had something else wrong with my installation earlier. After tearing it down and rebuilding it 4 times I finally got the correct sequence of tasks to set this up and have the Awesome Bar work properly on all of the tenant sites. Your commands fix it as long as it is done correctly for each tenant site.

This is still an issue with the install.py or one of the scripts that it calls. New production installations will all suffer with this.

BKM


#14

Just setup a new ERPNext server again today, and this BUG is still there!!

BKM


#15

Here we are almost a month later (24 days) and the ERPNext version has changed several times.

The problem was never fixed!!

Hard to believe. Only one person bothered to look at it in the github issue and he didn’t even bother to follow the instructions to see the bug. He just said “Works fine in my test account.” and never looked back.

I cannot believe that the developers are okay with allowing such a thing to still exist. It is stuff like this that causes new potential customer to go to competing programs to get their ERP services. I mean who would allow a bug that crashes the help feature to stay for so long and just ignore it?!?

What kind of impression does that leave on first time clients trying out ERPNext?

When I start this thread the versions were:

Versions:
ERPNext - 10.1.18
Frappe - 10.1.16

An now here we are at versions:

ERPNext - 10.1.23 master
Frappe - 10.1.24 master

Yet the bug still persists. I just spun up a fresh server this morning and something this simple is still hanging out there to interfere with potential new ERP clients.

I would not be so perturbed if I had only posted here about this. But I followed the correct portocol and I created a github issue (see link at top of thread) so it would be properly noted and it still gets ignored. THAT is what is so upsetting about it. All I ever want to do is help tidy up the things that get in the way of first adopters of this fine system. If the developer team doesn’t seem to care about such things, why should new adopters bother with us?!? It doesn’t set a good first impression.

Amazing…

BKM


#16

Hello @bkm

I understand your frustration. But looking at it from Frappe’s side there are new bug reports submitted several times a day that they need to check out. And many times they simply cannot reproduce them on their report. They also have a duty to look after their paying customers too before other general users which is understandable.

I think it’s a question of manpower to go through all these Github Issues and sometimes, like many things in life there is not enough time or resource to do everything as you would wish to.

What I suggest you try is to involve the community and the employees of Frappe that are supported by the Foundation, ie paying members of the community. If you send a quick polite message @achillesrasquinha i’m sure he may be able to take a quick look. Or at least point you in the direction of someone who can. The Foundation team who are employed by Frappe but paid for by the Foundation have a remit to improve the quality of the code as well as adding new features.

Also please make a quick animated gif of the issue. It’s not hard - I use Peek which is so easy to use and well maintained. Using these small videos does let the Devs understand more quickly than words can sometimes.

Good luck !


#17

Now I have to laugh out loud. That is the same thing the developer on github said to do, but I get the feeling they were just to lazy to read the instructions.

How do you make a GIF of installing ERPNext?
How do make a GIF of me pressing the ENTER key?!?

Come on… you can’t be serious?

The problem does NOT occur with a mouse click that you would be able to see in a stupid GIF. It requires a pressing of the ENTER key on the keyboard. That is why I think this GIF nonsense is just a way to get out of actually reading the instructions.

I really do not understand everyone’s fascination with these ridiculous GIF’s when they cannot possibly show you nearly as much as simply reading and following instructions.

If a developer is not willing to look at a problem just because it is not possible to make a GIF of the ENTER key, then that speaks volumes about either their skill level, or their laziness. Either way it does not set well with me.

  • I can see the point of being polite to the foundation if I ask them to look into it.
  • I can see the point of asking nicely for any effort.

What I cannot see is this nonsense of GIFs being able to tell the whole story. Why try to make a GIF of something that is impossible?!?

When 3 little instructions do the job best!

  • Install a fresh ERPNext production server using install.py
  • Complete the setup wizard.
  • Type “setup” into the awesome bar and press ENTER key

How do you make a stupid GIF for this?!?

The problem must be in the install.py script. Something is being left out.

BKM


#18

Let go of the GIF bone buddy :slight_smile: Take suggestions meaningful to you and ignore the rest.


#19

I give up…

Let it stay broken.

Moderator please close the thread. It is not worth keeping open.

BKM


#20

It seems like this would have to be a problem with setup.py. This thread was started on March 31st, and there was an update to setup.py on March 22nd by @anand
@anand Do you know of anything on your update that could have caused this?


#21

Why not think big? This calls for a test :wink:


#22

Well, that makes me laugh… I am not sure this is even on anyone’s radar. Every now and again someone will take a look, but nothing ever gets done for it.

Maybe one of the new recruits will get interested. Sad to have to say it that way though.

BKM


#23

Hello, @bkm888 Awesome bar working just fine in the latest version, with the use of “Enter” key as well! Would have attached a GIF for your reference but I have seen how “fascinated” you are by those, hence I’d just suggest you check out the latest version, and try using the search bar + ENTER key for navigation. Thanks for reaching out!


#24

Haha… Well it is good that it finally was fixed. I haven’t paid any attention to it for almost a year now because I had a fix for it when it occurs.

As far as GIFs go, they are too small, blurry, and move too fast for your eyes to follow. they do not have a pause button for you to try to follow along on the screens and all of my new users hated them. So, yeah… I’m not sure I would call that a “fascination” but I don’t really care how “fascinated” other people are with them either. (Thanks though for having read enough of my posts to even know about that :grin: )

BKM

Ok… so now Moderator, this thread can be closed!


#25