Auto re-order configured but notworking properly

Good day all

ERPNext: v12.10.1 (version-12)

Frappe Framework: v12.8.4 (version-12)

From what I have been reading, this should work as follows
Order in enough stock
Setup re-order level and QTY ( configured on the item page)
Use the stock until it gets to the re-order level.
At midnight, a MREQ should be generated.

THis is what I did

I ordered a few units of a particular item into the “Stores”
I then configured auto re-order : threshold 2 ; order quantity 3;
I then enter a sale for 1 unit which will bring the stock to 2
In the stock report for “Stores”, (for item ) there is an entry : Reorder level=2; reorder qty 3.

So it seem to have made the entry into the stock report for that item.
But there is no MREQ the next morning.

I found a few discussions about this with various outcomes. Some reporting re-ordering
does not work and some do. With some of these posts, version numbers V11 vs V12
was mentioned. So I am not clear if this was an issue with V11 and cleared up in V12
or if its still an issue?

I also found mention of the scheduler. i.e. is the scheduler running. In that case, I found
a suggestion that , to check if the scheduler is running I can use : bench doctor.
But my system says “doctor” is not an argument. And indeed if I run, bench --help, it
is not listed as an argument.

I also looked i the logs ( /var/log ) to see if I can see anything, but nothing.

I am asking for assistance please

  1. Am i understanding the setup procedure correctly?
  2. Is there a way for me to check that the scheduler is running?

Many thanks

Update -

I have done some more reading …

Last night my “bench doctor” command did not work … this morninig I get…

bench doctor
-----Checking scheduler status-----
Workers online: 3

but according to this doc…
https://frappeframework.com/docs/user/en/bench/guides/diagnosing-the-scheduler
I should be getting : workers online : 0

What does “workers online” mean, please?

also …

bench --site show-pending-jobs
-----Pending Jobs-----

also, the only “cron” entry I see ( as the frappe-bench user ) is related to backup, nothing
related to the scheduler.

Update

I have continued with my reading and testing:

  1. I did a test transaction on my test-system whereby I had stock and “sold” until the
    “Projected Qty” is below the re-order level. The system generated a material request
    as per the settings. I full-filled it the next day . In some of the posts I read that people
    were reporting that the system kept on generating a material request. I waited over
    another mid-night period but no extra material request was generated.

  2. I intend to do another test : buy stock, sell it until the projected qty is below the
    re-order level and then leaving it for 2 midnight-periods ( because it seems the
    re-ordering is done at midnight GMT ).

  3. I still could not find a way to check if the scheduler is running and if the command
    bench doctor actually implies that the scheduler is actually running. It does however seem
    that the scheduler is disabled by default. Which means that one will have to enable it:
    bench --site your.site enable-scheduler

  4. I did find a very usefull video on youtube…
    https://www.youtube.com/watch?v=YSnA547sCRo

1 Like

Another update:

I did perform the test as in (2) above where I buy stock until the projected qty is above the threshold for that item. I then “sell” it until the projected qty is below the stock threshold for that item. It did raise a “Purchase material request” when time went over a "mid-night period. I then left the request unserviced over another mid-night period. It did not raise another “Purchase material request”. So all seem to be functioning nominally.

I have to correct myself where I said the request is generated at midnight GMT. It is a midnight local time.

1 Like