App install at wrong path , how install app with correct path

i install app by command at location : /opt/bench/erpnext

  1. bench get-app
  2. bench --site demo1 install-app process_manufacturing
  3. bench start

app is not show in module list

now i try to remove by command at location : /opt/bench/erpnext

Command :

  1. bench --site demo1 uninstall-app process_manufacturing
  2. bench remove-app process_manufacturing

but error is comming

please help me to

  1. install app at correct location, means at which location i have to open terminal to run command
  2. how i can see process_manufacturing in erpnext
  3. how i remove wrong install app

partially solve
go to location - /opt/bench/erpnext

  1. bench get-app
  2. bench --site demo1 install-app process_manufacturing
  3. folder will appear on - /opt/bench/erpnext/apps
  4. click on top profile icon on header settings->my settingScreenshot%20from%202020-03-11%2016-20-04-cropped on Allow Modules , is your added module is display in that list then your app install successfully

now go desk and search for β€œopen your-app-name” now you can use it
eg. open process_manufacturing

if not appear in search then,

  1. search for Module Def list -> search your module name in list serach
    click on it to edit assign domain to it you can create domain name eg.process manufacturing
    save it

2.go to setting->domain setting->check your domain and save
3. search for DocType -> serach in table -> Process Manufacturing in module textbox
you will see name and module in table provide Role Permissions Manager to it .

now go desk and search for β€œopen your-app-name” now you can use it
eg. open process_manufacturing

by search you will open or use your app in erpnext
but it not display in desk .
if somebody know how to show your app on desk please reply

With just frappe installed, in /opt/bench/erpnext expect to see this:

β”œβ”€β”€ apps
β”‚   β”œβ”€β”€ frappe
β”œβ”€β”€ config
    β”œβ”€β”€ redis_cache.conf
    β”œβ”€β”€ redis_queue.conf
    └── redis_socketio.conf
β”œβ”€β”€ env
β”œβ”€β”€ logs
β”œβ”€β”€ Procfile
└── sites
    β”œβ”€β”€ apps.txt
    β”œβ”€β”€ assets
    β”œβ”€β”€ common_site_config.json
    └── site1.local
        β”œβ”€β”€ private
        β”œβ”€β”€ public
        └── site_config.json

Refer to

With erpnext installed too, I have this in apps.txt:

frappe@ubuntu:~/frappe-bench$ pwd
frappe@ubuntu:~/frappe-bench$ cat sites/apps.txt

So in your install-app case expect to see process_manufacturing added here too.

Search for this module name:

What may help is to run β€˜Reload’ in the Settings menu and also bench clear-cache

To discover bench commands run bench help

frappe@ubuntu:~/frappe-bench$ bench version
erpnext 12.4.3
frappe 12.2.1






terminal open to see version

pc@linux:/opt/bench/erpnext$ bench version
erpnext 12.x.x-develop
frappe 12.x.x-develop
process_manufacturing 1.0.0 beta

i reload in the setting menu and also bench clear-cache
but still icon not display on desk

if i enter in search bar for process manufacturing then it appear in search list

  1. after click on β€œopen process manufacturing” it open this window

now app is working fine. but, problem is β€œprocess manufacturing module” is not showing on desk

What you have seems reasonable to me!

But since you are on v12 develop, your problem may involve this Redesigning Desk

Maybe try your luck with version-12 branch as that is production

I suspect these may help too How to add cards

This is a fast moving target hence a learning challenge for most of us with each release :wink:

Thank you sir :slight_smile:

Yup search and read will inform your request How i can access ERPNEXT DATABASE AS UI and my xamp mysql database both on same pc

Yes actually
I install mysql workbench where i can see erpnext database table structure
When i run command bench start
Then i am unable to access my xampp localhost

I want to create rest api for laravel to erpnext to run laravel with mysql i need xampp

Please close this topic