Ansible error on install

Hello,

Im facing this error while trying to install bench can anyone help me?

Checking connectivity… done.
[WARNING]: Host file not found: /etc/ansible/hosts

 [WARNING]: provided hosts list is empty, only localhost is available

ERROR! Unexpected Exception: 'module' object has no attribute 'SSL_ST_INIT'
to see the full traceback, use -vvv
Traceback (most recent call last):
  File "install.py", line 381, in <module>
    install_bench(args)
  File "install.py", line 98, in install_bench
    run_playbook('develop/create_user.yml', extra_vars=extra_vars)
  File "install.py", line 323, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'))
  File "/usr/lib/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'develop/create_user.yml', '-e', '@/tmp/extra_vars.json']' returned non-zero exit status 250

An ‘ansible exit’ search here turned up this thread - mesg 4 may offer clues

Thank you for the reply, i checked it out but i have no clue on what to do i checked both links and i’m not even running macOS im using Ubuntu 15.10

1 Like

What python version are you running?

ok your trace indicates python 2.7 so that is reasonable

If you have python3 installed be sure to remove it!

To see the full traceback, use -vvv, so try this:

sudo python -vvv install.py --develop

Then with the full traceback these threads may give you ideas

@Oasis_Agano

Try to use a stable LTS
Ubuntu 14.04 or 16.

Hope this helps.

I installed OpenSSL manually using pip and things seem to work now

how to install manually

@Murugan You can Refer this link to install Erpnext manually

Thanks for reply. then i got one more error

ERROR! Unexpected Exception: ‘module’ object has no attribute ‘SSL_ST_INIT’
to see the full traceback, use -vvv
Traceback (most recent call last):
File “install.py”, line 381, in
install_bench(args)
File “install.py”, line 98, in install_bench
run_playbook(‘develop/create_user.yml’, extra_vars=extra_vars)
File “install.py”, line 323, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘develop/create_user.yml’, ‘-e’, ‘@/tmp/extra_vars.json’]’ returned non-zero exit status 250

Which Maira DB version you are you using?
Can you please try with manual installation

How to find version i don’t know

you can run comand in frappe-bench folder
bench Mysql
you can find Maria DB version there

‘mariadb-client-core-10.0’ (universe)
‘mysql-client-core-5.7’ (main)

Not sure if this is resolved, but the pattern looks the same as this: Easy Install develop fails with ERROR! Unexpected Exception, this is probably a bug: 'module' object has no attribute 'SSL_ST_INIT'