Allow on submit for custom field not working if workflow enabled

I have added a custom field to sales invoice.
I have check the box Allow on Submit for that field.
With workflow enabled.
Once I submit the sales invoice only the System User can edit that field.
If I disable the workflow all roles with permission to Sales Invoice can edit the field.

I have answered my own question.
Basically there has to be a State defined allowing the role to edit the document.
In My Case I need to have a state named Approved and only allow edit for role Employee