After login JSON Error (Session start failed)

Hi,

I made a new installation (Version=Frappe Framework: v10.1.48 (100,101,118,101,108,111,112))
After the installation is complete, it sometimes fails and forces you to login again.

Error: (Session start failed) - Object of type ‘bytes’ is not JSON serializable

1 Like

I’m having something similar after I login in and redirect to /desk
b'develop' is not JSON serializable
and in the browser console
Uncaught boot failed
I guess we have the same issue
Refreshing the page worked for me and I get localStorage cleared in the browser console, but I don’t know if that’s the right thing to do

ERPNext: v10.1.53 (100,101,118,101,108,111,112)
Frappe Framework: v10.1.48 (100,101,118,101,108,111,112)

I too experienced the same issue and also resorted to just refreshing the page.
I’m just hoping someone can suggest how to get round the error

Was this on fresh install or already running instance. User is admin or non-admin system user ?

@trentmu @joshiparthin fresh installation was done. I’m logging in as an administrator. After the initial installation, it failed. Previously, the permissions were not set. Need to set file permissions again after the initial installation?

1 Like

If there are no customisations, try

$bench update 

it should pull some latest updates which might solve the issue for you. I think you should try master branch for frappe and erpnext. They are more stable.

Regards,

Parth Joshi

Hi,

@joshiparthin I already installed the system yesterday. I tried the update but the result is the same. Maybe I’ve done the installation again with the idea that I’ve done wrong and the error continues.

Fixed for me after I used master

No more errors after I used:

ERPNext: v10.1.53 (master)
Frappe Framework: v10.1.48 (master)

instead of

ERPNext: v10.1.53 (100,101,118,101,108,111,112)
Frappe Framework: v10.1.48 (100,101,118,101,108,111,112)

@trentmu - Thanks for responding- this was on a fresh installation- I had not created any custom doctype.

I did the same too- but it would be good to know the fix for that message

Same happened to me, a fresh installation on Ubuntu with Easy install steps, How to fix it please ?

  1. Updated all Ubuntu dependencies and rebooted (not sure if this is required)
  2. Installed Pre-requisites manually and did required reboots
  3. Fetched repos from GitHub manually
  4. Installed Bench manually and created frappe user with required permissions
  5. Installed ERPNext and configured it manually

I did several reboots in after some of the steps, I don’t know what is wrong with the automatic installation script, but I know that doing everything manually worked for me

I’ve even tried manually installing the new ERPNext develop v11 version, it works like a charm, without any error…

This goes away after clearing browser cookies.

I will try that after reinstalling using the same method again and post a replay about it, but if that’s the reason, it would be better if there is a message like “Please clear your browser cookies” instead of the old message

Ya it should be better handled but as you are on develop branch and it is expected you know some basics.
This usually does not happen on master branch when in production mode as bench update results into doing that for you.

I used sudo bench setup production then bench update --patch to run it as production on port 80, and it was giving me the same message each time I log in, it was showing on the console that I am using master but in the browser using 100,101,118,101,108,111,112

Dispatched a Fix

1 Like

That is awesome to hear! I have never ever had success with the manual installation…I’ve come to accept my fate as one destined to use the easy script :frowning:

Confirm it was on Ubuntu 18.04?

Did you follow the steps outlined here : https://github.com/frappe/bench

If not, I’d appreciate if you could steer me in the right direction as doing the manual install has now gotten on my bucket list.

Thanks

This topic was automatically closed after 38 hours. New replies are no longer allowed.