ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

After bench start got this error


#1

after bench start got this error
17:49:04 system | redis_socketio.1 started (pid=26796)
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.888 * Increased maximum number of open files to 10032 (it was originally set to 1024).
17:49:04 redis_socketio.1 | .
17:49:04 redis_socketio.1 | .-__ ''-._ 17:49:04 redis_socketio.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
17:49:04 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 17:49:04 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 17:49:04 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 17:49:04 redis_socketio.1 | |-. ._ / _.-' | PID: 26803 17:49:04 redis_socketio.1 |-._ -._-./ .-’ .-’
17:49:04 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:04 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 17:49:04 redis_socketio.1 |-._ -._-..-’.-’ .-’
17:49:04 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:04 redis_socketio.1 | |-.
-._ _.-'_.-' | 17:49:04 redis_socketio.1 |-._ -._-.
.-’.-’ .-’
17:49:04 redis_socketio.1 | -._-..-’ _.-’
17:49:04 redis_socketio.1 | -._ _.-' 17:49:04 redis_socketio.1 |-.
.-’
17:49:04 redis_socketio.1 |
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.889 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.889 # Server started, Redis version 3.0.6
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.889 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.889 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:49:04 redis_socketio.1 | 26803:M 13 Apr 17:49:04.889 * The server is now ready to accept connections on port 12000
17:49:04 system | worker_long.1 started (pid=26802)
17:49:04 system | web.1 started (pid=26811)
17:49:04 system | watch.1 started (pid=26813)
17:49:04 system | redis_queue.1 started (pid=26812)
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 * Increased maximum number of open files to 10032 (it was originally set to 1024).
17:49:04 redis_queue.1 | .
17:49:04 redis_queue.1 | .-__ ''-._ 17:49:04 redis_queue.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
17:49:04 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 17:49:04 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 17:49:04 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 17:49:04 redis_queue.1 | |-._ ._ / _.-' | PID: 26818 17:49:04 redis_queue.1 |-._ -._-./ .-’ .-’
17:49:04 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:04 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 17:49:04 redis_queue.1 |-._ -._-..-’.-’ .-’
17:49:04 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:04 redis_queue.1 | |-.
-._ _.-'_.-' | 17:49:04 redis_queue.1 |-._ -._-.
.-’.-’ .-’
17:49:04 redis_queue.1 | -._-..-’ _.-’
17:49:04 redis_queue.1 | -._ _.-' 17:49:04 redis_queue.1 |-.
.-’
17:49:04 redis_queue.1 |
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 # Server started, Redis version 3.0.6
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:49:04 redis_queue.1 | 26818:M 13 Apr 17:49:04.915 * The server is now ready to accept connections on port 11000
17:49:05 system | schedule.1 started (pid=26815)
17:49:05 system | worker_default.1 started (pid=26804)
17:49:05 system | redis_cache.1 started (pid=26824)
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.986 * Increased maximum number of open files to 10032 (it was originally set to 1024).
17:49:05 redis_cache.1 | .
17:49:05 redis_cache.1 | .-__ ''-._ 17:49:05 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
17:49:05 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 17:49:05 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 17:49:05 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 17:49:05 redis_cache.1 | |-._ ._ / _.-' | PID: 26837 17:49:05 redis_cache.1 |-._ -._-./ .-’ .-’
17:49:05 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:05 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 17:49:05 redis_cache.1 |-._ -._-..-’.-’ .-’
17:49:05 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 17:49:05 redis_cache.1 | |-.
-._ _.-'_.-' | 17:49:05 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
17:49:05 redis_cache.1 | -._-..-’ _.-’
17:49:05 redis_cache.1 | -._ _.-' 17:49:05 redis_cache.1 |-.
.-’
17:49:05 redis_cache.1 |
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.987 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.987 # Server started, Redis version 3.0.6
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.987 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.987 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:04.987 * The server is now ready to accept connections on port 13000
17:49:05 system | worker_short.1 started (pid=26816)
17:49:05 system | socketio.1 started (pid=26805)
17:49:05 socketio.1 | /home/lmc/erpnext/apps/frappe/socketio.js:8
17:49:05 socketio.1 | var { get_conf, get_redis_subscriber } = require(’./node_utils’);
17:49:05 socketio.1 | ^
17:49:05 socketio.1 |
17:49:05 socketio.1 | SyntaxError: Unexpected token {
17:49:05 socketio.1 | at exports.runInThisContext (vm.js:53:16)
17:49:05 socketio.1 | at Module._compile (module.js:374:25)
17:49:05 socketio.1 | at Object.Module._extensions…js (module.js:417:10)
17:49:05 socketio.1 | at Module.load (module.js:344:32)
17:49:05 socketio.1 | at Function.Module._load (module.js:301:12)
17:49:05 socketio.1 | at Function.Module.runMain (module.js:442:10)
17:49:05 socketio.1 | at startup (node.js:136:18)
17:49:05 socketio.1 | at node.js:966:3
17:49:05 system | socketio.1 stopped (rc=1)
17:49:05 system | sending SIGTERM to redis_socketio.1 (pid 26796)
17:49:05 system | sending SIGTERM to worker_long.1 (pid 26802)
17:49:05 system | sending SIGTERM to watch.1 (pid 26813)
17:49:05 system | sending SIGTERM to redis_queue.1 (pid 26812)
17:49:05 system | sending SIGTERM to web.1 (pid 26811)
17:49:05 system | sending SIGTERM to schedule.1 (pid 26815)
17:49:05 system | sending SIGTERM to worker_default.1 (pid 26804)
17:49:05 system | sending SIGTERM to redis_cache.1 (pid 26824)
17:49:05 system | sending SIGTERM to worker_short.1 (pid 26816)
17:49:05 redis_socketio.1 | 26803:signal-handler (1555157945) Received SIGTERM scheduling shutdown…
17:49:05 redis_cache.1 | 26837:signal-handler (1555157945) Received SIGTERM scheduling shutdown…
17:49:05 redis_queue.1 | 26818:signal-handler (1555157945) Received SIGTERM scheduling shutdown…
17:49:05 system | schedule.1 stopped (rc=-15)
17:49:05 system | worker_default.1 stopped (rc=-15)
17:49:05 system | worker_short.1 stopped (rc=-15)
17:49:05 system | worker_long.1 stopped (rc=-15)
17:49:05 system | web.1 stopped (rc=-15)
17:49:05 system | watch.1 stopped (rc=-15)
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:05.288 # User requested shutdown…
17:49:05 redis_cache.1 | 26837:M 13 Apr 17:49:05.288 # Redis is now ready to exit, bye bye…
17:49:05 system | redis_cache.1 stopped (rc=-15)
17:49:05 redis_socketio.1 | 26803:M 13 Apr 17:49:05.289 # User requested shutdown…
17:49:05 redis_socketio.1 | 26803:M 13 Apr 17:49:05.290 # Redis is now ready to exit, bye bye…
17:49:05 system | redis_socketio.1 stopped (rc=-15)
17:49:05 redis_queue.1 | 26818:M 13 Apr 17:49:05.318 # User requested shutdown…
17:49:05 redis_queue.1 | 26818:M 13 Apr 17:49:05.318 # Redis is now ready to exit, bye bye…
17:49:05 system | redis_queue.1 stopped (rc=-15)


#2

Try this…

sudo systemctl restart supervisor

or

sudo supervisorctl restart all