Adding addtional column in Journal List

Hi,

We wanted to add the ‘posting_date’ field to the list of displayed information when viewing the Jounal Entry List.

However, after customising the DocType (ticking “In ListView”), the Journal Entry List replaced the current ‘Reference Number’ column with the Posting date instead of adding it in as an additional column.

Is this correct? If so, how would be get Title/Status/Posting Date/Reference Number as the columns.

Any ideas? Many thanks

@Ardan due to space limited, only the first few columns will show in the listview.

You can define a rule for Title to add one of them in the title.

https://manual.erpnext.com/contents/customize-erpnext/document-title

ERPNext: v7.0.51
Frappe Framework: v7.0.37

Following suggestion¹ from the second post, we want to add brand into the title field of Item master. item_name and brand work perfectly fine alone each, but all the following combinations fail:

{item_name}{brand}
{item_name},{brand}
{item_name};{brand}
{item_name}:{brand}
{item_name} {brand}
item_name,brand
item_name;brand
item_name:brand
item_name brand

The error message is:

Title field must be a valid fieldname

Is it possible to add several values in this field? What is the proper syntax for this?
Thanks.

¹ — working link to the article: https://frappe.github.io/erpnext/user/manual/en/customize-erpnext/document-title

Sorry, really don’t like to bump threads, but is there any solution for the issue?

Hello,

Here are the steps.

  1. Insert a custom field called “title” in the Item master.
  2. Set title field as hidden.
  3. In the title field, set default value as - {item_name} and {brand}
  4. In the customize form for Item, enter title field as “title”.
  5. Update customize form.

2 Likes

Thank you for help.

I’ve followed all the steps you suggested, but now the Item list is showing items with literally “{item_name} and {brand}” title.
Is there something wrong in the form customized as shown here? https://imgur.com/a/gzYm2

“{item_name} and {brand}” must be placed into the options field, not into the default field. After changing the form fields, I had to open and save all items for the changes to take effect.

1 Like