Accounts Missing Under Tree View (Chart of Accounts)

Hello,

As you can see at the screenshot, my chart of accounts is empty at newly installed deployment. It’s Frappe master and ERPNext Developing. I can see the accounts under the company settings so accounts created successfully.

When I click “Expand All” i get this error;

Traceback (most recent call last):
File “/home/thiras/frappe-bench/apps/frappe/frappe/app.py”, line 57, in application
response = frappe.handler.handle()
File “/home/thiras/frappe-bench/apps/frappe/frappe/handler.py”, line 22, in handle
data = execute_cmd(cmd)
File “/home/thiras/frappe-bench/apps/frappe/frappe/handler.py”, line 53, in execute_cmd
return frappe.call(method, **frappe.form_dict)
File “/home/thiras/frappe-bench/apps/frappe/frappe/init.py”, line 935, in call
return fn(*args, **newargs)
File “/home/thiras/frappe-bench/apps/frappe/frappe/desk/treeview.py”, line 19, in get_all_nodes
data = tree_method()
TypeError: get_children() takes at least 3 arguments (0 given)

Also I get empty list at task tree view (like chart of accounts).

I did bench update and bench update --patch successfully. No error has appeared.

Browser console is also clean. No error appears.

image

I’ve also got the exact same problem updating from v9 to v10

The frappe.log is below. I did make a bench backup before, how can I get this back?

Site: site1.local
Form Dict: {
“cmd”: “frappe.desk.treeview.get_all_nodes”,
“parent”: “Accounts”,
“tree_args”: “{“doctype”:“Account”,“company”:“BLAH”,“parent”:“Accounts”}”,
“tree_method”: “erpnext.accounts.utils.get_children”
}
Request Error
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 62, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 22, in handle
data = execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 53, in execute_cmd
return frappe.call(method, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 939, in call
return fn(*args, **newargs)
TypeError: get_all_nodes() takes exactly 3 arguments (2 given)
[ERROR] 2018-03-03 08:16:51,625 | /home/frappe/frappe-bench/apps/frappe/frappe/utils/error.py:
New Exception collected with id: 2018-03-03 08:16:51.531507-192.168.123.69-1c5

What version of Frappe and Erpnext you’re on ?
Did you update both of them ?

I’ve not restored the backup that I did from the erpnext v9, should I try a restore or will that breakup things even more. I have a CoA and admin for this year and last year in it.

Here’s the version info:

ERPNext: v10.1.4 (master)

ERPNext Shopify: v2.0.25 (develop)

Frappe Framework: v10.1.1 (master)

Meeting: v0.0.1

After restoring the backup, did you do a bench migrate ?

yes I did, and I’m still getting the same error.

When I got to erpnext.mydomain.com/desk#List/Account/List

I can see the entire list of the accounts, but the chart of accounts tree is empty, so the accounts are there but there is something that is not working it to render the tree. I’ve not played with erpnext sufficiently to know if the database is safe to use and if I can continue work with it.

I also tried to set the CoA through the Company link, but it does not seem to have any effect on the CoA, on the page: erpnext.mydomain.com/desk#Tree/Account which shows as empty.

I’ve created a new sales invoice, and when I try to submit it, it says Sales Invoice SINV - 00003: Account Income - BLAH cannot be a Group, this is very strange… since its always been a group before, it contains two other children Income items.

Hey Guys, I’m sort of stuck here. Is there a way to recover the entire installation on another system with the backup? How can I recover all the configuration of the site, products etc?