500 Internal Server Error shortly after installation

Hey guys,

I installed a new ERPNext yesterday in a vBox. I got through the setup of ERPNext. But when the installation is done it redirects me to the login page. From there on I get error 500 on anything. I already tried restarting. The ERPNext logs dir is empty. Since I use reverse proxy of nginx (the delivered config), I added an error_log to the server{}. This log remains empty, too. When I go onto the server with "w3m http://localhost:8000/" I get a 404 not found.
If you need anything else to help me please feel free to ask.

Thanks in advance
Lukas Wagner



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/939f9472-6cb9-4e23-b315-74e0b9a5698d%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Hey Lucas,

On Thu, Apr 10, 2014 at 2:11 PM, Lukas Wagner
ap...@gmail.com wrote:

Hey guys,

I installed a new ERPNext yesterday in a vBox. I got through the setup of
ERPNext. But when the installation is done it redirects me to the login
page. From there on I get error 500 on anything. I already tried restarting.
The ERPNext logs dir is empty. Since I use reverse proxy of nginx (the
delivered config), I added an error_log to the server{}. This log remains
empty, too. When I go onto the server with “w3m http://localhost:8000/” I
get a 404 not found.

For the 500, were you able to capture any tracebacks?
Try running the development server (frappe --serve) to get a clue.

We merged model-cleanup branch to develop today, will make a tag and
let you know when it’s installable. I hope you are not running version
4 for production work.

If you need anything else to help me please feel free to ask.

Thanks in advance
Lukas Wagner


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/939f9472-6cb9-4e23-b315-74e0b9a5698d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks,

Pratik
erpnext

I’m currently only testing.
But for production work I will need the shopping cart.

On 10.04.2014 11:47, Pratik Vyas wrote:

Hey Lucas,

On Thu, Apr 10, 2014 at 2:11 PM, Lukas Wagner
ap...@gmail.com wrote:

Hey guys,

I installed a new ERPNext yesterday in a vBox. I got through the setup of
ERPNext. But when the installation is done it redirects me to the login
page. From there on I get error 500 on anything. I already tried restarting.
The ERPNext logs dir is empty. Since I use reverse proxy of nginx (the
delivered config), I added an error_log to the server{}. This log remains
empty, too. When I go onto the server with “w3m http://localhost:8000/” I
get a 404 not found.
For the 500, were you able to capture any tracebacks?
Try running the development server (frappe --serve) to get a clue.

We merged model-cleanup branch to develop today, will make a tag and
let you know when it’s installable. I hope you are not running version
4 for production work.

If you need anything else to help me please feel free to ask.

Thanks in advance
Lukas Wagner


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/939f9472-6cb9-4e23-b315-74e0b9a5698d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks,


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note

You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/53466BE0.80403%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hey Pratik,

as you said I started gunicorn manually and got the following output: http://pastebin.com/mDQkSjSX
I hope that helps.

Thanks,
Lukas



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/53468D4E.5050506%40gmail.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Lucas

On Thu, Apr 10, 2014 at 5:53 PM, Lukas Wagner
ap...@gmail.com wrote:

Hey Pratik,

as you said I started gunicorn manually and got the following output:
http://pastebin.com/mDQkSjSX
I hope that helps.

I think that you did not start it from the sites directory.

Thanks,
Lukas


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/53468D4E.5050506%40gmail.com.

For more options, visit https://groups.google.com/d/optout.

Thanks,

Pratik
erpnext

Hi Pratik,

yes, you are right. I ran it again with supervisor off. This time i got
that output: http://pastebin.com/ZMQ55Eu1
It’s a UnicodeDecodeError.
Hope this time it helps :smiley:

Thanks,
Lukas

On 10.04.2014 14:36, Pratik Vyas wrote:

Hi Lucas

On Thu, Apr 10, 2014 at 5:53 PM, Lukas Wagner
ap...@gmail.com wrote:

Hey Pratik,

as you said I started gunicorn manually and got the following output:
http://pastebin.com/mDQkSjSX
I hope that helps.
I think that you did not start it from the sites directory.

Thanks,
Lukas


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/53468D4E.5050506%40gmail.com.

For more options, visit https://groups.google.com/d/optout.

Thanks,


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note

You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/53469F6C.9060306%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hey Lucas,

On Thu, Apr 10, 2014 at 7:11 PM, Lukas Wagner
ap...@gmail.com wrote:

Hi Pratik,

yes, you are right. I ran it again with supervisor off. This time i got that
output: http://pastebin.com/ZMQ55Eu1
It’s a UnicodeDecodeError.
Hope this time it helps :smiley:

Looks like headers are not in ascii range (similar issue prevents
frappe to run on mod_wsgi). I really want to replicate this and fix
it. Did you make a weird web page? If your data isn’t sensitive, can
you send me your db dump?

Thanks,

Pratik
erpnext

Hi Pratik,

Appreciate this is an old thread, however when I ran guincorn as suggested from the sites directory I just get 404's now - used to work prior to an update today.

Any ideas?

/data/www/erpnext/frappe-bench/env/bin/gunicorn -b 127.0.0.1:8000 -w 2 -t 120 frappe.app:application
2014-05-07 13:59:01 [21706] [INFO] Starting gunicorn 18.0
2014-05-07 13:59:01 [21706] [INFO] Listening at: http://127.0.0.1:8000 (21706)
2014-05-07 13:59:01 [21706] [INFO] Using worker: sync
2014-05-07 13:59:01 [21711] [INFO] Booting worker with pid: 21711
2014-05-07 13:59:01 [21712] [INFO] Booting worker with pid: 21712

Damian

On Thursday, April 10, 2014 8:05:48 PM UTC+4, Pratik Vyas wrote:
Hey Lucas,

On Thu, Apr 10, 2014 at 7:11 PM, Lukas Wagner
<ap...@gmail.com> wrote:
> Hi Pratik,
>
> yes, you are right. I ran it again with supervisor off. This time i got that
> output: http://pastebin.com/ZMQ55Eu1
> It's a UnicodeDecodeError.
> Hope this time it helps :D
>

Looks like headers are not in ascii range (similar issue prevents
frappe to run on mod_wsgi). I really want to replicate this and fix
it. Did you make a weird web page? If your data isn't sensitive, can
you send me your db dump?


Thanks,
--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ade30c94-b3e4-4aff-b7a3-7ec50ef4d2d3%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
Hi Pratik,

Trying with frappe yeilds the same results:

:/data/www/erpnext/frappe-bench/sites$ /data/www/erpnext/frappe-bench/env/bin/frappe --serve
 * Running on http://0.0.0.0:8000/
 * Restarting with reloader
127.0.0.1 - - [07/May/2014 14:06:10] "GET / HTTP/1.1" 404 -
127.0.0.1 - - [07/May/2014 14:06:11] "GET / HTTP/1.1" 404 -
127.0.0.1 - - [07/May/2014 14:06:12] "GET / HTTP/1.1" 404 -

There is an app here that ran fine previously.

d

On Wednesday, May 7, 2014 5:01:20 PM UTC+4, Damian Dimmich wrote:
Hi Pratik,

Appreciate this is an old thread, however when I ran guincorn as suggested from the sites directory I just get 404's now - used to work prior to an update today.

Any ideas?

/data/www/erpnext/frappe-bench/env/bin/gunicorn -b 127.0.0.1:8000 -w 2 -t 120 frappe.app:application
2014-05-07 13:59:01 [21706] [INFO] Starting gunicorn 18.0
2014-05-07 13:59:01 [21706] [INFO] Listening at: http://127.0.0.1:8000 (21706)
2014-05-07 13:59:01 [21706] [INFO] Using worker: sync
2014-05-07 13:59:01 [21711] [INFO] Booting worker with pid: 21711
2014-05-07 13:59:01 [21712] [INFO] Booting worker with pid: 21712

Damian

On Thursday, April 10, 2014 8:05:48 PM UTC+4, Pratik Vyas wrote:
Hey Lucas,

On Thu, Apr 10, 2014 at 7:11 PM, Lukas Wagner
<ap...@gmail.com> wrote:
> Hi Pratik,
>
> yes, you are right. I ran it again with supervisor off. This time i got that
> output: http://pastebin.com/ZMQ55Eu1
> It's a UnicodeDecodeError.
> Hope this time it helps :D
>

Looks like headers are not in ascii range (similar issue prevents
frappe to run on mod_wsgi). I really want to replicate this and fix
it. Did you make a weird web page? If your data isn't sensitive, can
you send me your db dump?


Thanks,
--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/b6e15bf2-d5c8-42f2-84ec-6732d3bd5324%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
Got it - for some reason sites/currentsite.txt had ../erpnext/conf/ in it...

I changed it to read:

../sites/conf/

And it works!

d

On Wednesday, May 7, 2014 5:07:53 PM UTC+4, Damian Dimmich wrote:
Hi Pratik,

Trying with frappe yeilds the same results:

:/data/www/erpnext/frappe-bench/sites$ /data/www/erpnext/frappe-bench/env/bin/frappe --serve
 * Running on http://0.0.0.0:8000/
 * Restarting with reloader
127.0.0.1 - - [07/May/2014 14:06:10] "GET / HTTP/1.1" 404 -
127.0.0.1 - - [07/May/2014 14:06:11] "GET / HTTP/1.1" 404 -
127.0.0.1 - - [07/May/2014 14:06:12] "GET / HTTP/1.1" 404 -

There is an app here that ran fine previously.

d

On Wednesday, May 7, 2014 5:01:20 PM UTC+4, Damian Dimmich wrote:
Hi Pratik,

Appreciate this is an old thread, however when I ran guincorn as suggested from the sites directory I just get 404's now - used to work prior to an update today.

Any ideas?

/data/www/erpnext/frappe-bench/env/bin/gunicorn -b 127.0.0.1:8000 -w 2 -t 120 frappe.app:application
2014-05-07 13:59:01 [21706] [INFO] Starting gunicorn 18.0
2014-05-07 13:59:01 [21706] [INFO] Listening at: http://127.0.0.1:8000 (21706)
2014-05-07 13:59:01 [21706] [INFO] Using worker: sync
2014-05-07 13:59:01 [21711] [INFO] Booting worker with pid: 21711
2014-05-07 13:59:01 [21712] [INFO] Booting worker with pid: 21712

Damian

On Thursday, April 10, 2014 8:05:48 PM UTC+4, Pratik Vyas wrote:
Hey Lucas,

On Thu, Apr 10, 2014 at 7:11 PM, Lukas Wagner
<ap...@gmail.com> wrote:
> Hi Pratik,
>
> yes, you are right. I ran it again with supervisor off. This time i got that
> output: http://pastebin.com/ZMQ55Eu1
> It's a UnicodeDecodeError.
> Hope this time it helps :D
>

Looks like headers are not in ascii range (similar issue prevents
frappe to run on mod_wsgi). I really want to replicate this and fix
it. Did you make a weird web page? If your data isn't sensitive, can
you send me your db dump?


Thanks,
--
Pratik
erpnext



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ba841c2b-6075-4c67-bea7-4d41cde35e4d%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.