404 Page Docker Installation

I am new in Frappe/ErpNext and following frappe_docker/single-server-example.md at main · frappe/frappe_docker · GitHub

  1. configurator container is exited and I cant to see logs
    with docker exec -it

  2. bench cant start

I find the same problem articles and add same SITE_NAME in .env SITES and VM /etc/hosts

Can you confirm there is common_site_config.json with the appropriate values for db and redis hosts exists in sites volume? you can start one container with that volume attached or check /var/lib/docker/volumes on docker host.

There is no bench start in production containers if you are looking for that.

db_host, redis_cache, redis_queue, redis_socketio, socketio_port are needed in common_site_config.json for all bench processes to start.

Dear, revant_one, thank you.
Can you explain me please, where I can found common_site_config.json? file in frappe_docker dir?
I cant get permission acces in /var/lib/docker/volumes this is my virtualization platform rules

Start a new container with volume attached: (Check docker docs for more info)

docker run --rm -v <project-name>-sites:/sites -it frappe/erpnext-worker:version-13 bash

you will find /sites/common_site_config.json in the container started with above command.

To access /var/lib/docker you need root access. Attach volume to container recommended over accessing volumes from /var/lib/docker

image
No common_site_config.json in container dir, but site is exist

Also I have a question about configure.py container. I found in topic frappe_docker/setup-options.md at main · frappe/frappe_docker · GitHub , has advice to copu example-env to .env, but in example-env Redis configuration is empty… It is the reason why config.py container stopped?

P.S. Thank you so much

it means there is volume permission error

make sure your site volume is owned by gid:uid 1000:1000

chown -R 1000:1000 /path/to/sites

make sure you use docker exec --user root ... or you won’t be allowed to change ownership of files.

after ownership is fixed run the configure container again

it remains empty when you start redis containers.
if you use external redis hosts then you need to set it.

related issue:

Ok, It’s done priveleges

But conteiner still exited

check if the config file exists now?

container exits after creating the config file


Not found

try running it manually.

or try running bench set-config.

no need of being root for that.